Results 1 to 12 of 12
  1. #1
    Steven_Mc's Avatar
    Join Date
    Jan 2002
    Location
    Colorado Springs, CO
    Member #
    452
    Images
    11

    Chinaman's shake down run

    This may be the first trip report I've ever written...

    Weather turned out perfect. Plenty of others on the trail, but just RollingBlubber and I from the board. Jeep worked well, biggest casualty was the loss of my license plate somewhere along hwy24 on the way out. I've got a few bugs to work out but by and large the jeep performed really well. I've got a leak somewhere in the rear ARB as the compressor runs almost constant and the brakes seemed to fade at points(pedal very near the floor, but I still had braking power.), something to do with the hydroboost I'm sure, but I need to do some research and diagnosis. A few scratches and dings, but nothing that shouldn't be expected. Otherwise a great maiden voyage!

    Many thanks to RollingBlubber for guiding this glorified web wheeler through an actual trail. His little samurai and his driving skills made even the hardest lines look easy.

    I got rejected on the far left line of the whale's tail and same on the stairs... had to take the easier lines, but I attribute it to lack of driver skill more than anything.

    Looking forward to many more trails this summer!

    Few videos:


    https://youtu.be/jlq3QaSAfwA

    https://youtu.be/Euan_Tk82Mw

    Photos: Flickr Album

    Last edited by Steven_Mc; March 26th, 2017 at 06:50 PM.
    - Steven

  2. #2
    vb's Avatar
    Join Date
    Sep 2002
    Location
    montrose
    Member #
    1190
    Images
    29
    " Every soul deserves a shot at a Cadillac, but not everyone should be guaranteed a Cadillac". Ben Stein

  3. #3
    Glad to see you had a great trip, beautiful rig!

  4. #4
    Thanks for the vid's! Looks like a fun day!
    We live in a age of entitlement.

  5. #5
    kemosabee's Avatar
    Join Date
    Apr 2005
    Location
    Pagosa Springs, CO
    Member #
    6264
    Looks like you had a blast, thanks for sharing!
    2007 Tundra TRD, 2001 Taco ExtendedCab TRD, 2010 Forester (GoKart)

    I've had your Jeep thing...Now it burns when I pee.

  6. #6
    Great first trip report. I hope there are many more to come! Glad the jeep worked out great. Sounds like you got some air in the brake system or your booster is failing??
    God Forgives, Rock's Don't www.ucora.org
    1973 Bronco, 351 SEFI, Locked, discs, 35's ZF-5spd and Atlas 4spd. 235:1 Crawl Ratio

  7. #7
    tjjared413's Avatar
    Join Date
    Feb 2005
    Location
    arvada, Co
    Member #
    5925
    Images
    16
    jeep looks good in the dirt...!

    we ran carnage both ways yesterday and had good weather as well!
    rig- 04 TJ for going to the malls and tow pig- 15 F350

  8. #8
    Steven_Mc's Avatar
    Join Date
    Jan 2002
    Location
    Colorado Springs, CO
    Member #
    452
    Images
    11
    Quote Originally Posted by 74BuckinBronc View Post
    Great first trip report. I hope there are many more to come! Glad the jeep worked out great. Sounds like you got some air in the brake system or your booster is failing??
    I just replaced the brake lines all around for longer lines, thought I bled them well enough, but that's my first culprit.


    Sent from my iPhone using Tapatalk Pro

  9. #9

  10. #10
    Thanks for posting!

  11. #11
    If you're willing to try, I think low on the rear quarter area where you can see both the front and rear tires would be best. You can get a better sense of what the truck is doing. But then it's more vulnerable...

  12. #12
    that wouldn't work for me as the really isnt a rear quarter on my rig. the rear of the chassis is over the rear tire. next time out i'll try some other spots. my biggest problem is remembering to turn it on.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •