Results 1 to 22 of 22
  1. #1

    CB won't receive

    I bought a new Cobra 29 LTD CB radio. I installed it and calibrated it (it has a built-in meter). During calibration it responds as expected.
    The first time I go to use it I don't get any reply so I stop my Jeep and run over to the guy I am trying to talk to. I find out he can hear me but I can't hear him. I have checked over everything I can think of. It is getting power.
    In case there was slight moisture in the connection at the antenna I re-did that connection using dielectric grease.
    Here is the main symptom that I think will be the key to my troubleshooting: when I turn up both the squelch and the volume I don't hear any squelch or static. That made me think it was a problem with the speaker. I also have an external speaker. I tried it with and without the external speaker. Still no go.
    Another reason I know it's not the speaker is it sometimes makes noise, such as when a friend pulled up 3 feet from my jeep I got a squeal from my speaker when I tried testing (such as feed back).

    Anyone have any ideas?
    Last edited by BusaDave9; July 21st, 2011 at 08:41 PM.
    '79 CJ5, 304 V8, T18, Dana 20 with 3 to 1 TeraLow, 36" SuperSwamper SX, 4.88 gears
    OX Locker Rear, Detroit Locker Front, MileMarker Hydraulic Winch

  2. #2
    clemsonkrawler's Avatar
    Join Date
    Apr 2006
    Location
    lost at sea... Orientation: SNOW LOVER!
    Member #
    9146
    its broken.
    Pimpin aint easy.

  3. #3
    Quote Originally Posted by clemsonkrawler View Post
    its broken.
    Thanks
    Your probably right but I wanted to make sure. Cobra is a good brand and the 29 LTD is one of their more expensive models. I would hate to return it and find out it was an antenna ground or something else like that.

    My last CB didn't work either. I don't think it would transmit or receive but I didn't do much troubleshooting.

  4. #4
    Wulf's Avatar
    Join Date
    Nov 2008
    Location
    over here
    Member #
    15883
    Quote Originally Posted by BusaDave9 View Post
    Thanks
    Your probably right but I wanted to make sure. Cobra is a good brand and the 29 LTD is one of their more expensive models. I would hate to return it and find out it was an antenna ground or something else like that.

    My last CB didn't work either. I don't think it would transmit or receive but I didn't do much troubleshooting.
    Well double check those things first then

    Did you change anything (ground setup, coax. cable, antenna) between your old and new CBs?
    8 Hz WAN IP

  5. #5
    clemsonkrawler's Avatar
    Join Date
    Apr 2006
    Location
    lost at sea... Orientation: SNOW LOVER!
    Member #
    9146
    ILl prolly get banned for linking another site, but it has a few things to try before you toss it at someone.

    http://www.jeepforum.com/forum/f20/c...eceive-436471/

  6. #6
    I did check the antenna ground and I have 0 ohms from the antenna ground to the chassis. I have not replaced the coax cable to the antenna.

  7. #7
    9fngrs's Avatar
    Join Date
    Feb 2007
    Location
    Colo spgs
    Member #
    11696
    Images
    1
    Mine did the same thing and it ended up being the mic. If i plugged in headphones to the jack on the back I could hear but very faintly. It never occured to me that the mic was bad but a friend suggested changing it and now it works fine. Weird but it worked for me. Cobra 29 for me too.
    locked and longarmed on 37's and beadlocks

  8. #8
    X2 on the mic
    91 Toyota ex cab 4x4 silver with 5.5in lift, 33's, rear locker, HAM radio, GPS, CB radio, 9000lb winch. New Car Sales Manager at Auto nation GMC Park Meadows

    I do everything the voices in my wifes head tell me to do.

  9. #9
    Oscar's Avatar
    Join Date
    Jan 2004
    Location
    Colorado Springs
    Member #
    3575
    If your are transmitting but not receiving it's not your antenna or coax line.
    Wandering in the wilderness.

  10. #10
    Quote Originally Posted by 9fngrs View Post
    Mine did the same thing and it ended up being the mic.
    Quote Originally Posted by Oscar View Post
    If your are transmitting but not receiving it's not your antenna or coax line.
    Sounds good. I will try another mic in the morning.

  11. #11
    I replaced the mic and it still isn't working.
    I called up Cobra and they stepped me through the same troubleshooting I already did. They are asking me to send it in to them and 10 days later they will replace or repair it.

  12. #12
    9fngrs's Avatar
    Join Date
    Feb 2007
    Location
    Colo spgs
    Member #
    11696
    Images
    1
    That's cool that they will fix or replace it.

  13. #13
    Quote Originally Posted by 9fngrs View Post
    That's cool that they will fix or replace it.
    It doesn't look like they did either.
    I sent my CB into Cobra and it still doesn't work.
    The main symptom: I turn up the volume and the squelch and is still don't hear any squelch or static. I have been trying to do broadcast tests but I never hear anything back. FNA

    What do you guys think? Did Cobra do anything to try to fix my CB?
    They said they did "internal calibration". I know I got the same CB I sent in.
    Now I can't return my CB where I got it (on the internet) because it has been more than 30 days.
    Monday I can call Cobra but I am pissed.

    If it was the antenna then I wouldn't be able to send or receive.

  14. #14
    Digger's Avatar
    Join Date
    Feb 2002
    Location
    Buffalo Creek, CO
    Member #
    510
    Images
    106
    turn the squelch down...counter clockwise

    turn the RF gain all the way up.. clockwise

    you should hear static... and any strong or weak signals in the area
    ASE Master Tech
    '95 5.9 XJ on 44s and 35s
    Owner/Operator 4 On The Floor Automotive

  15. #15
    Digger's Avatar
    Join Date
    Feb 2002
    Location
    Buffalo Creek, CO
    Member #
    510
    Images
    106
    and a couple of questions... not to insult you, just to clarify....

    do you know how the squelch and rf gain dials work for your radio?

  16. #16
    al24's Avatar
    Join Date
    Apr 2002
    Location
    Under the mast.
    Member #
    688
    Images
    24
    I've got one in the big truck. It's really quiet if no ones talking. Do like Digger suggested. Might also turn the anl off. Did you switch it from swr to receive after you set the swr?
    Any fool can criticize, condemn and complain and most fools do. Benjamin Franklin
    klaatu barada nikto

    Quid Futuis

  17. #17
    Mikegyver shadetreezj's Avatar
    Join Date
    Nov 2003
    Location
    Democratic republic of Denver
    Member #
    3219
    Images
    54
    I thought mine was all fubar, then I noticed the pa switch was on.

    Let us know what you find.
    My Iphone is smarter than your honor student.....

    I SUCK AT EGGS

  18. #18
    I turned the volume all the way up.
    I switched the PA/CB to CB
    I turned the RF gain all the way up (clockwise).
    I turned the squelch all the way counter clockwise. Nothing out of the speakers.
    I have followed the manual and when I called Cobra the tech walked me through the same procedures.

  19. #19
    Mikegyver shadetreezj's Avatar
    Join Date
    Nov 2003
    Location
    Democratic republic of Denver
    Member #
    3219
    Images
    54
    have you tried a different antenna cable? and. or antenna?

    I would lend you one, but you're in a different time zone or something.

  20. #20
    Quote Originally Posted by shadetreezj View Post
    have you tried a different antenna cable? and. or antenna?

    I would lend you one, but you're in a different time zone or something.
    No. but if it was an antenna or cable then I wouldn't think I wouldn't be able to send.
    I can transmit. Others can hear me, but when they reply, I can't hear them. It is almost like the speaker doesn't work.

    I'll see if I can try another antenna.

  21. #21
    9fngrs's Avatar
    Join Date
    Feb 2007
    Location
    Colo spgs
    Member #
    11696
    Images
    1
    Have you tried an external speaker or putting headphones in the speaker jack to see if you can hear then?

  22. #22
    Mikegyver shadetreezj's Avatar
    Join Date
    Nov 2003
    Location
    Democratic republic of Denver
    Member #
    3219
    Images
    54
    I don't know, seems like the last of the unknowns to rule out

Similar Threads

  1. Marine to Receive MoH Sept. 15
    By DaJudge in forum General Chit Chat
    Replies: 4
    Last Post: August 15th, 2011, 02:02 PM
  2. Buddy will receive the engraved silver-plated dog bowl
    By al24 in forum General Chit Chat
    Replies: 1
    Last Post: April 23rd, 2010, 07:13 PM
  3. 2 Springs men receive Presidential Pardons
    By JimhatTJ in forum General Chit Chat
    Replies: 5
    Last Post: March 26th, 2008, 02:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •