View Full Version : '06 CTD trans 'hunt' 'shuttle shift'

The Man With The Plan
November 15th, 2010, 11:53 AM
Anyone else having these issues? Stock tranny did it, my BD tranny did it, and now the tranny that Rob @ Performance Car and Truck built is doing it. All my research points to this being the issue, and the TSB to repair it (http://www.cumminsforum.com/forum/technical-service-bulletins-recall-support/100097-tranny-hunting.html), has already been done. A little more digging around, and I found this: http://www.dieseltrans.com/dodge/shift_enhancer.htm. Has anyone used this before? Are there better options?

November 15th, 2010, 12:22 PM
I have yet to find a "good" solution to eliminate it completely. I have an '05, and it does the same damn thing. It was horrible when I had my Edge hooked up.

The DTT enhanser I've heard works fairly well. I have yet to buy it cuz I'm a cheap ass these days....but it's been on the back of my mind for awhile now. I've talked to a couple guys that are running them, and they all have had good results.

Chris Halvorson
November 15th, 2010, 01:22 PM
The DTT shift enhanser works well from what I have been told. Most people don't want to spend even more money after dropping 4K+ on a trans.

The Man With The Plan
November 15th, 2010, 05:36 PM
$250 is a drop in the bucket after $4k+! However, it's one of those things that the tranny builder should know about (IMHO), and include with the build. Not that Rob did a half-a$$ job though. I called around to a few shops today looking to see if anyone had one local, and half the people didn't even know what it was. The other half didn't sell them. Seems kind of odd to me since it appears to be a very common problem.

Chris Halvorson
November 15th, 2010, 06:41 PM
You would be amazed at what people skimp on...